Wo bleibt die IP-Adresse

Dieses Thema im Forum "Hardware" wurde erstellt von Thorsten, 11. Oktober 2001.

  1. Thorsten

    Thorsten New Member

    Hallo!

    Ich habe ein echt merkwuerdiges Problem unter Mac OS X v10.1:
    Ich wollte das Netzwerk manuell konfigurieren, und habe eingegeben als IP-Adresse: 192.168.1.4, als Teilnetzmaske 255.255.255.0 und unter Router nichts.
    So, normalerweise sollte nun im Kontrollfeld Sharing eben diese IP-Adresse zu sehen sein, aber Pustekuchen! Trotzdem habe ich File- und Web Sharing aktiviert, und hoffte nun durch Eingabe der eben definierten IP-Adresse im Internet Explorer auf die Apache-Testseite zu kommen. Der Browser findet aber nichts unter dieser Adresse. Also habe ich das Netzwerk-Dienstrogramm geoeffnet und die eingegebene Adresse "angepingt", aber es wird gemeldet "No route to host".
    Also tippte ich im Terminal mal "httpd" ein, was mir schon vorher mal jemand empfohlen hatt,um an Informationen zu kommen. Da kam dann folgendes raus:

    Processing config directory: /private/etc/httpd/users
    Processing config file: /private/etc/httpd/users/torti.conf
    [Wed Oct 10 01:14:11 2001] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    fopen: Permission denied
    httpd: could not open error log file /private/var/log/httpd/error_log.

    Mit 127.0.0.1 funktionierte dann natuerlich alles, denn das ist ja die Standard-IP-Adresse fuer den localhost.
    Aber nun lange Rede, kurzer Sinn: Wie kann ich denn eine IP-Adresse funktionierend manuell konfigurieren.

    Mac OS X v10.1 habe ich nach zig Versuchen niegelnagelneu nach Initialisierung auf die Platte gespielt, aber es ergab sich nichts neues.

    Danke schon mal fuer Tipps,
    Thorsten

    PB G4, 384 MB RAM, Mac OS X v10.1, 10 GB HD
     
  2. MACrama

    MACrama New Member

    ganz einfach in der httpd.conf gibts einen eintrag ServerName
    da gibts du halt irgendeinen servernamen ein...oder servernamen ein

    klar 127.0.0.1 ist localhost..
    läuft der apache auf dem selben rechner, von dem du eine site aufrufen willst?

    dann bist du mit 127.0.0.1 genau richtig..

    ra.ma.
     
  3. Thorsten

    Thorsten New Member

    Wie lautet denn der Pfad zur httpd.conf?

    Und mit dem servernamen meinst Du die gewuenschte IP-Adresse?

    Der Apache-Server laeuft in diesem Fall auf dem gleichen Rechner, von dem ich sie versuchte testweise aufzurufen. Ich will aber eine andere IP-Adresse, als die vom localhost definieren, um Web Sharing-technisch Windows-Rechnern den Zugriff auf meine lokalen Seiten zu ermoeglichen.

    Gruss,
    Thorsten
     
  4. MACrama

    MACrama New Member

    gut der pfad...
    /etc/httpd/httpd.conf

    bist du bereits in ein netzwerk eingebunden? oder hast du das erst vor...?
    wenn nicht dann kannst du erst eine ip definieren wenn du in einem netzwerk bist.. als single user(none network) gilt die datei hosts(mach mal "cat /etc/hosts") und da fährt die eisenbahn drüber..
    natürlich kannst du in der hosts eine ip hinzufügen...obs funkt und obs sin macht sei dahingestellt

    ja du kannst in der httpd.conf eine ip als servernamen vergeben...

    ra.ma.
     
  5. Thorsten

    Thorsten New Member

    ...sorry!

    Habe eben auch Deine Antwort an Larsi gelesen, und es scheint mir, als haetten wir das selbe Problem. Also: Der Mac steht alleine da...

    Trotzdem Danke fuer die Hilfe!

    Gruesse aus London,
    Thorsten
     
  6. MACrama

    MACrama New Member

    bidde...gern geschehen...

    ra.ma.
     
  7. Larsi

    Larsi New Member

    Ha, endlich einer, der mich versteht :).

    Was mich verwundert ist, dass dieses Phänomen unter Mac OS X 10.0.1-4 nicht auftritt - erst seit MacOS X 10.1. Das Problem muss doch aber zu lösen sein.

    Eigentlich brauche ich ja die IP-Adresse bloß, um auf meinen QuickTimeStreamingServer zuzugreifen, denn der geht nur über eine "echte" IP-Adresse und nicht über 127.0.0.1.

    Ich hoffe bloß, dass das ein Bug ist und mit dem nächsten Update behoben wird.

    Larsi
     
  8. trocadero

    trocadero New Member

    Hat mir leider nicht weiter geholfen.
    Ich will mit meinem iBook 466 SE (192 MB) und seiner eingebauten Ethernet Karte Internet per Kabel haben. Kabelfirma hat mir eine feste IP-Adresse zugewiesen sowie zwei DNS und die Adresse des Routers.

    httpd.conf habe ich geandert, der ServerName entspricht der Router-Adresse. Pingen bringt nur die Meldung "No route to host".

    Weisst Du Abhilfe?
    Gruesse aus Bukarest
    Christian
     
  9. MACrama2

    MACrama2 New Member

    hi
    apache hat nix mit router zu tun...
    für internetzugang brauchst du keinen apache..der apache ist ein webserver kein
    router..

    willst du auf deinem ibook deine website hosten?

    der servername sollte ein name sein
    zb. myserver.domain.com (info.apple.com)
    wobei myserver bzw. info der ServerName ist...

    ra.ma.
     
  10. Pjotr

    Pjotr New Member

    Mac OS X: Check Ethernet Frame Types When IP Communication Appears Not to Work states: "Mac OS X 10.0 and later work with the Ethernet II frame type for all IP communications. Check the type used by another device when IP communication with that device does not work."

    http://docs.info.apple.com/article.html?artnum=106524

    Keine Ahnung, ob dir das weiterhilft..

    Pjotr
     
  11. Pjotr

    Pjotr New Member

    Noch was bzgl. Kabelmodem, allerdings unter Verwendung von DHCP
    (Text aus macfixit.com):
    Pjotr

    Problems using DHCP and cable modems in OS X 10.1

    Chris Cooper spotted an Apple Discussions Board thread that discusses a problem related to using DHCP with cable modems and OS X 10.1. The issue occurs on many different models of Macs and cable modems and providers.

    Barry Sharp pointed us to the same thread, and particularly cited his own posting: "I had upgraded to 10.1 this past Monday on my iMac DV attached to AT&T's broadband via Cable modem via DHCP that has worked flawlessly -- until this morning. My cable modem setup using DCHP worked all the time under 10.0.4. Now I find myself in the exact same situation as many who have posted here."
     
  12. trocadero

    trocadero New Member

    Nein, meine Website will ich erst spaeter hosten. Ich will einfach nur Internet ueber Kabel nutzen, bekomme es aber nicht hin (muss deswegen auf einem Windows-Rechner schreiben). Ich bin, ehrlich gesagt, ratlos, was ich im iBook alles noch konfigurieren kann. 10.0.4 laesst ja nicht viel Spielraum. Ich gebe Dir gerne weitere Einzelheiten, wenn Du mir sagen koenntest, welche Du brauchst, um mein Problem einzukreisen. Ich habe vom ISP bekommen:
    Ein Kabel-Modem, meine eigene IP-Adresse, zwei DNS, eine Router-IP und einen simplen Domain-Namen (ess.ro)

    Danke fuer Deine Hilfe!
    Christian
     
  13. MACrama2

    MACrama2 New Member

    nagut...erstmal dazu brauchst du keinen apache...

    dann geh mal ins netzwerk menü..
    dann auf ethernet manuell
    stellen
    deine ip eintragen, die ip des router und die dns server ins feld dns..

    nächster Reiter PPPOE
    aktivieren
    username und alles eintragen was verlangt wird...

    hoffe das hilft dir..
    ra.ma.
     
  14. trocadero

    trocadero New Member

    Das habe ich probiert, auch PPPoE. Ohne Erfolg. PPPoE ist, glaube ich, nicht zu waehlen, weil ich eine permanente Verbindung habe. (Auf dem Windows-Rechner muss ich auch im IE den Punkt eintragen: Keine Verbindung waehlen, also auch keinen User-Namen etc.)
    Das ist genau der Punkt, den ich nicht verstehe. Alle Daten sind korrekt eingetragen und es passiert dennoch nichts.
    Weiter unten hat mir jemand geantwortet und auf die Einwahl ueber DHCP verwiesen. Leider hilft auch das nicht, weil ich durch die permanente Verbindung ja eine feste IP-Adresse habe und keine dynamische. Was nun?
    Christian
     
  15. trocadero

    trocadero New Member

    Danke fuer den Link, ich kontaktiere mal meinen ISP und frage nach dem IP-System. Versuche es zumindest, in Rumaenien dauert manches etwas laenger...
    Christian
     
  16. Thorsten

    Thorsten New Member

    Hallo!

    Ich habe ein echt merkwuerdiges Problem unter Mac OS X v10.1:
    Ich wollte das Netzwerk manuell konfigurieren, und habe eingegeben als IP-Adresse: 192.168.1.4, als Teilnetzmaske 255.255.255.0 und unter Router nichts.
    So, normalerweise sollte nun im Kontrollfeld Sharing eben diese IP-Adresse zu sehen sein, aber Pustekuchen! Trotzdem habe ich File- und Web Sharing aktiviert, und hoffte nun durch Eingabe der eben definierten IP-Adresse im Internet Explorer auf die Apache-Testseite zu kommen. Der Browser findet aber nichts unter dieser Adresse. Also habe ich das Netzwerk-Dienstrogramm geoeffnet und die eingegebene Adresse "angepingt", aber es wird gemeldet "No route to host".
    Also tippte ich im Terminal mal "httpd" ein, was mir schon vorher mal jemand empfohlen hatt,um an Informationen zu kommen. Da kam dann folgendes raus:

    Processing config directory: /private/etc/httpd/users
    Processing config file: /private/etc/httpd/users/torti.conf
    [Wed Oct 10 01:14:11 2001] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    fopen: Permission denied
    httpd: could not open error log file /private/var/log/httpd/error_log.

    Mit 127.0.0.1 funktionierte dann natuerlich alles, denn das ist ja die Standard-IP-Adresse fuer den localhost.
    Aber nun lange Rede, kurzer Sinn: Wie kann ich denn eine IP-Adresse funktionierend manuell konfigurieren.

    Mac OS X v10.1 habe ich nach zig Versuchen niegelnagelneu nach Initialisierung auf die Platte gespielt, aber es ergab sich nichts neues.

    Danke schon mal fuer Tipps,
    Thorsten

    PB G4, 384 MB RAM, Mac OS X v10.1, 10 GB HD
     
  17. MACrama

    MACrama New Member

    ganz einfach in der httpd.conf gibts einen eintrag ServerName
    da gibts du halt irgendeinen servernamen ein...oder servernamen ein

    klar 127.0.0.1 ist localhost..
    läuft der apache auf dem selben rechner, von dem du eine site aufrufen willst?

    dann bist du mit 127.0.0.1 genau richtig..

    ra.ma.
     
  18. Thorsten

    Thorsten New Member

    Wie lautet denn der Pfad zur httpd.conf?

    Und mit dem servernamen meinst Du die gewuenschte IP-Adresse?

    Der Apache-Server laeuft in diesem Fall auf dem gleichen Rechner, von dem ich sie versuchte testweise aufzurufen. Ich will aber eine andere IP-Adresse, als die vom localhost definieren, um Web Sharing-technisch Windows-Rechnern den Zugriff auf meine lokalen Seiten zu ermoeglichen.

    Gruss,
    Thorsten
     
  19. MACrama

    MACrama New Member

    gut der pfad...
    /etc/httpd/httpd.conf

    bist du bereits in ein netzwerk eingebunden? oder hast du das erst vor...?
    wenn nicht dann kannst du erst eine ip definieren wenn du in einem netzwerk bist.. als single user(none network) gilt die datei hosts(mach mal "cat /etc/hosts") und da fährt die eisenbahn drüber..
    natürlich kannst du in der hosts eine ip hinzufügen...obs funkt und obs sin macht sei dahingestellt

    ja du kannst in der httpd.conf eine ip als servernamen vergeben...

    ra.ma.
     
  20. Thorsten

    Thorsten New Member

    ...sorry!

    Habe eben auch Deine Antwort an Larsi gelesen, und es scheint mir, als haetten wir das selbe Problem. Also: Der Mac steht alleine da...

    Trotzdem Danke fuer die Hilfe!

    Gruesse aus London,
    Thorsten
     

Diese Seite empfehlen