X86free installieren

Dieses Thema im Forum "Hardware" wurde erstellt von Hans Solo, 9. Oktober 2001.

  1. Hans Solo

    Hans Solo New Member

    Hallo Leute,
    hat jemand von Euch bereits X86free installiert?
    Gleich zu Beginn teilt einem das Terminal mit, daß eine X Session läuft und fragt, ob man fortfahren will. In der Installationsanleitung wird aber vor einer Installation bei laufender X Session ausdrücklich gewarnt. Wie stoppt man diese?
    Vielen Dank schonmal
    Hans Solo
     
  2. MACrama

    MACrama New Member

    hmmm..du hast schon eine Xsession laufen?
    hast du einenanderen xwindows emulator laufen?

    ra.ma.
    ps. wie startet man das verdammte ding--> X86free?
    bricht immer ab mit can't connect ....
     
  3. Hans Solo

    Hans Solo New Member

    Nein. Sofern ich weiß, läuft kein anderer Emulator.
    Wie man startet, kann ich noch nicht sagen, da X86free ja nicht installiert ist.
    Mache die ersten Schritte in der Unix-Welt.
    Hans Solo

    P.S.: Die mit OS X.1 mitgelieferte Broschüre ist zwar schick aber angesichts der radikal neuen Systemarchitektur wohl eher ein Scherz.
     
  4. MACrama

    MACrama New Member

    aja

    Welcome to the XFree86 4.1.0 installer
    >>
    You are strongly advised to backup your existing XFree86 installation
    before proceeding. This includes the /usr/X11R6 and /etc/X11
    directories. The installation process will overwrite existing files
    in those directories, and this may include some configuration files
    that may have been customised.

    If you are installing a version different from 4.1.0, you
    may need an updated version of this installer script.

    Do you wish to continue? (y/n) [n] y
    >>
    so schuat das bei mir aus...

    komsmt du soweit?

    ra.ma.
     
  5. Hans Solo

    Hans Solo New Member

    Soweit bin ich bereits gekommen, d.h. der Installationsprozeß ist bereits über diesen Punkt hinaus.
    Dann kommt aber die Frage mit der X Session. Der Unix Befehl zum beenden einer App ist glaube ich "kill". Aber was soll man killen?
     
  6. MACrama

    MACrama New Member

    vorsicht mit dem kill..

    gib mal ps ein(als root) und schau ob irdenwas läuft..

    ra.ma.
     
  7. MACrama

    MACrama New Member

    öha

    " ps aux " eingeben.
     
  8. Hans Solo

    Hans Solo New Member

    Hab leider einen Termin und kann nicht weiter miträtseln. Ich schau später (gegen sieben) noch mal rein.
    Hans Solo
     
  9. Carsten

    Carsten New Member

    Ich hab es zwar auch noch nicht zum laufen bekommen aber gib bei der Anmeldung zu OS X >console als Name ein. Könnte sein das Dein Problem dadurch behoben wird. Durch diese Anmeldung wird der graphische Kern abgeschlaltet und Du hast sozusagen Darwin vor Dir. Dort kannst Du dich als root mit deinem Passwort anmelden. Um wieder zur graphischen Oberfläche zu kommen mußt du logout eingeben.
     
  10. Carsten

    Carsten New Member

    Bei mir bricht xFree auch immer den Start ab.
    Du versuchst xfree über das Terminal mittels startx -- -quartz oder?
    Hast Du schon probiert xfree mit dem Programm XDarwin ( http://mrcla.com/XonX/ ) zu starten?
     
  11. MACrama

    MACrama New Member

    startet mit garnix

    es sollte laut FAQ ein, x86config oder x86cfg file geben aber pustekuchen...
    ohne configuration läuft da mal gar nix denkich

    sogar mit dem startfile XDarwinQuartz geht nix..

    irgenwo haperts da...

    ra.ma.
     
  12. MACrama

    MACrama New Member

    is nicht der sinn der sache...
    wills ja unter aqua laufen haben..

    ra.ma.
     
  13. Carsten

    Carsten New Member

    set path = ( $path /usr/x11r6/bin )'. Danach starte xfree mit startx -- -quartz.
    Vergiss die Eingabe von x86config oder x86cfg dies ist unter OS X bzw. Darwin nicht nötig.

    http://www.macosx.org/xwindows.html ist vielleicht hilfreich.
     
  14. MACrama2

    MACrama2 New Member

    hmm..das werd ich morgen mal testen...

    danke einstweilen für den tipp...

    ra.ma.
     
  15. Hans Solo

    Hans Solo New Member

    So bin jetzt auch auf Eurem Stand. XDarwin ist installiert und läuft auch bei mir nicht. Starte ich mit "startx -- -quartz", erfolgt die Meldung:

    "assert failed on line 454 of darwinKeyboard.c!"

    Auf der Fink-Seite (http://fink.sourceforge.net/faq/packages.php#xfree-keymapping) wird dieses Problem behandelt. Man soll eine Preference Datei (~/Library/Preferences/org.xfree86.XDarwin.plist)löschen. Allerdings ist diese Datei weit und breit nicht auf meiner Platte zu finden.
    Seid Ihr vorangekommen?
    Hans Solo
     
  16. Carsten

    Carsten New Member

    rm org.xfree86.XDarwin.plist '.

    Der Fehler trat bei mir auch immer auf hab xfree dann aber zum laufen bekommen indem ich XDarwin von http://mrcla.com/XonX heruntergeladen habe und die Dateien in den xfree Pfad kopiert habe, nur per Doppelklick will xfree noch nicht starten.

    Wenn Du "startx -- -quartz" eingibst wird xfree im Vollbild-Modus gestartet um wieder auf die OS X Oberfläche zurückzukehren mußt Du alt-Apfel-A drücken. Wenn Du xfree mit "startx -- -rootless" startest liegt xfree auf der OS X Oberfläche.
     
  17. MACrama2

    MACrama2 New Member

    >>..Du in dem Pfad bist drück 2*esc dann
    kannst ...
    oder einfach die tab taste...

    bei mir ffunkt keines von beiden...

    er startet zwar, dann kommt ein schwarzer screen, und dann bricht das ganze mit ner fehlermeldung ab... die ich jetzt net auswendig weiß

    pfff..blödes ding..hab alles so gemacht wies in der anleitung stand...

    ra.ma.
     
  18. Carsten

    Carsten New Member

    Is wahlich bescheuert mit der Installation. Ich habe bestimmt ca. 15 mal installiert und deinstalliert bis es lief.
    Lade mal XDarwin von der oben angegeben Seite herunter, enpacke dies mit StuffIt und kopier dann die jeweiligen Dateien über das Terminal mit dem Befehl cp -Rf in die Ordner /usr/x11r6/bin und /usr/x11r6/man.
    Denn bevor ich diese Dateien dort installiert hatte hatte ich auch nur ein schwarzen Bildschirm.
     
  19. Hans Solo

    Hans Solo New Member

    Carsten, Dein Tip war Gold wert. Habe das Update XDarwin-1.0a3 von der XonX-Seite geladen, entpackt und in die entsprechenden Verzeichnisse kopiert. XFree läßt sich bei mir auch (der neuen XDarwin.App sei es gedankt) aus Aqua starten.
    Mal sehen, ob sich jetzt Software aktivieren läßt.
    Vielen Dank Euch beiden und bis demnächst
    Hans Solo
     
  20. Hans Solo

    Hans Solo New Member

    Hallo Leute,
    hat jemand von Euch bereits X86free installiert?
    Gleich zu Beginn teilt einem das Terminal mit, daß eine X Session läuft und fragt, ob man fortfahren will. In der Installationsanleitung wird aber vor einer Installation bei laufender X Session ausdrücklich gewarnt. Wie stoppt man diese?
    Vielen Dank schonmal
    Hans Solo
     

Diese Seite empfehlen