XP-PC als Server, Mac als Client - wie?

Dieses Thema im Forum "Hardware" wurde erstellt von xco, 4. August 2009.

  1. xco

    xco New Member

    Die Suche in alten Themen hat mich nicht so ganz weitergebracht, daher mal ganz genau gefragt.

    Mein Macbook Pro hat Mac OSX 10.5.7, mein PC hat Windows XP SP2, und das Ding soll der Server werden, dank sehr üppiger Ausstattung mit einem RAID.

    Beide hängen mit Ethernetkabeln (und das Macbook und ein weiteres XP-Notebook manchmal per WLan) an einem Telekom-Speedport W701v, der wohl auch als Router funktioniert.

    Wie kann ich ohne zusätzliche Kosten und möglichst unkompliziert vom Mac auf einige Verzeichnisse oder ganze Volumes des PC und vom PC auf einige Ordner auf dem Mac zugreifen, jeweils mit vollen Schreib- und Leserechten?
     
  2. MACaerer

    MACaerer Active Member

    Das sollte problemlos gehen. Der XP-Server müsste unter "Freigaben" in der Seitenleiste eines geöffneten Fensters des MBP erscheinen und kann dort ausgewählt werden. Alternativ geht es auch im Menü "Gehe zu => Mit Server verbinden". Der Server hat vermutlich als Dateisystem NTFS. Das kann der Mac ohne zusätzliche Erweiterungen zwar lesen, aber nicht beschreiben. Du musst also auf dem Mac ein Programm wie "Paragon" oder "MACFuse" installieren.

    MACaerer
     
  3. dimoe

    dimoe New Member

    auf dem PC und em Mac mußt Du die entsprechenden Ordner freigeben

    Damit ein PC auf einen Mac zugreifen kann, muß die TCP-IP-Adresse die gleiche sein:

    z.B.
    alle in der Umgebung "Workgroup"
    Server:
    192.168.0.1

    Notebook
    192.168.0.2

    Mac
    192.168.0.3

    Standardgateway/Router ist dann die Nummer des Telekom-Speedport
     
  4. dimoe

    dimoe New Member

    Blödsinn, im Netzwerk spielt das überhaupt keine Rolle

    Nur bei direkt angeschlossenen Festplatten sind das gute Programme.
     
  5. xco

    xco New Member

    Also, so weit bin ich jetzt:

    Auf dem PC gibt es eine Arbeitsgruppe, und es wurden ein Volume und ein Ordner freigegeben.

    Auf dem Mac habe ich mit Apfel-K das hier gemacht:
    smb://<IP-adresse>/<Freigabename>

    Jetzt taucht links in der Leiste unter "Freigaben" der Name der Arbeitsgruppe auf. Ich sehe rechts drei Symbole:

    "EFF" - das ist das Volume
    "testordner" - der Ordner
    "SharedDocs" - nie gehört

    Ich dachte, nun hätte ich es geschafft... denkste

    Beim Doppelklick auf eines der Symbole bekomme ich den Hinweis:

    "Der Vorgang konnte nicht abgeschlossen werden, da das Originalobjekt für 'EFF' nicht gefunden wurde."

    Es klappt bei keinem der drei.

    Was habe cih falsch gemacht?
     
  6. dimoe

    dimoe New Member

    Vielleicht mußt Du noch das richtige Kennwort eingeben.

    Leider ist das beim Mac mit 10.5. nicht so einfach, da es sich automatisch als Gast anmelden will.
    Man kann aber versuchen auf "Verbinden als" zu klicken, ich schaffe es aber auch nicht immer, daß das Fenster sich öffnet.

    Ich speichere danach die Verbindung (bei den Dokumenten) im Dock, um die Verbindung schnell wieder zu bekommen.
     
  7. xco

    xco New Member

    So, das habe ich auch probiert. Ohne Erfolg.

    Mittlerweile fand ich noch das hier auf der Apple-Website:

    http://support.apple.com/kb/HT1568?viewlocale=de_DE

    Die unter 3. aufgeführten verschiedenen Versionen, die man bei der Eingabe benutzen kann, habe ich durch, immer derselbe Fehler.

    Bis Punkt 11 komme ich einigermaßen klar, danach übersteigt es meine Fähigkeiten...
     
  8. MACaerer

    MACaerer Active Member

    Wieder was gelernt, aber nach einigem Überlegen ist das eigentlich klar :embar:

    MACaerer
     
  9. dimoe

    dimoe New Member

    Da weiß ich jetzt auch nicht mehr weiter.

    Vielleicht hilft es, wenn man die TCP-IP-Adressen mal auf "automatisch zuweisen" stellt.

    Oder bei der DNS kann man noch die Router-Adresse eintragen.
     
  10. xco

    xco New Member

    Habe ich probiert, die Routeradresse stimmt auch.

    Inzwischen habe ich mal folgendes getan:

    1. Die Rechner angepingt, funzt.

    2. Firewalls aus, und bei der Telekom, von der der Router ist nachgefragt: die eingebaute Firewall arbeitet nicht zwschen den internen Ports, sondern nur nach außen.

    3. Auf dem Mac Samba-Sharing eingestellt, um herauszufinden, ob der Rückweg geht. Im Prinzip dasselbe in Grün: der Windows PC sieht den Mac, kommt aber auch nicht auf die Ordner.

    4. Auf dem PC Bonjour und den Treiber des USB-Druckers installiert, der am Mac hängt - DAS FUNKTIONIERTE AUF ANHIEB.

    5. Meinem Applehändler und einem alten Freund (15 Jahre Mac-Erfahrung) geschildert, beide wissen auch nicht weiter.
     
  11. dimoe

    dimoe New Member

    Ins Internet kommen beide/alle Rechner?

    Das ist jetzt was für Experten:
    Schreibe doch mal alles ab (oder Screenshots)
    (Wenn es Dir zu öffentlich ist, als PM):

    Windows:
    System: Computername/Netzwerkkennung/Domäne
    Ordner: Freigabe/Benutzerrechte
    Netzwerkverbindung Eigenschaften: TCP-IP, IP-Adresse, DNS-Server

    Mac:
    Netzwerk: DHCP, DNS-Server, Suchdomäne
    Sharing: Filesharing, Freigegebene Ordner, Benutzer, Optionen (über SMB freigeben)

    Router:
    IP-Adresse
     
  12. xco

    xco New Member

    So, Problem gel&#246;st - es war ein WINDOWS-PROBLEM.

    Ich habe mir mal in der Windowsverwaltung die Meldungen angesehen. Dabei fiel mir der Eintrag auf, da&#223; ein gewisser "irpstacksize" zu klein sei. Sowas aber auch, ein bis dato v&#246;llig Unbekannter, der mir in die Suppe spuckte.

    Also, mal kurz gegoogelt. Die Fehlerbehebung war ja soooo einfach: lediglich regedit aufrufen... geht nicht, weil eine DLL fehlte... die erst mal besorgt, dann regedit gestartet, in der Registry eine neue DWORD-Ressource angelegt, die dort leider, leider einfach fehlte, den Wert gem&#228;&#223; Seite 12.135 der Microsoft-Hilfeseiten auf 30 gesetzt, neu gestart - und zack, es geht.

    Und jetzt wei&#223; ich auch wieder, warum ich Windows eigentlich so hasse... dieser Mist hat mich Stunden gekostet.


    Allen, die sich hier f&#252;r mich abgem&#252;ht haben, ein gro&#223;es Danke!
     
  13. dimoe

    dimoe New Member

    gerngeschehen
     

Diese Seite empfehlen