Zugriffsrechte von Ordnern

Dieses Thema im Forum "Software" wurde erstellt von kurtiiii, 10. Juli 2005.

  1. kurtiiii

    kurtiiii New Member

    Hallo Helfende,
    habe ein kleines, nerviges Problem in unserem gemischten Netzwerk (Win XP, OSX Panther, je zwei gleiche benutzer als admin):
    Wenn ich von XP als benutzer1 auf dem mac einen Ordner Anlege hat benutzer2 auf dem mac nur Leserechte. Von XP aus kann ich den Schreibschutz nicht mehr aufheben. Von OSX aus kann ich die Zugriffsrechte zwar wieder verändren, aber nur für jeden verdammte Ordner einzeln.
    Ich hoffe, dass ich mein Problem verstanden wird und jemand eine Lösung hat. Das Problem nervt nämlich jeden zweiten Tag.

    Vielen Dank,
    Lukas.
     
  2. macbike

    macbike ooer eister

    Man könnte da was mit AppleScript und den Ordneraktionen machen, das alle neu erstellten Ordner bestimmte Zugriffsrechte bekommen.

    Beispielsweise durch das Script:
    on adding folder items to this_folder after receiving added_items
    try
    tell application "Finder"
    set everyones privileges to read write
    end tell
    end try
    end adding folder items to

    bekommen alle Lese- und Schreibzugriff auf den neu erstellten Orden, wenn das Script als Ordneraktion an den freigegebenen Ordner angehängt ist. Probier sowas mal.
    Dieses "set everyones privileges to read write" kann man auch gegen "set owner privileges to read only/read write/write only/none / group privileges toread only/read write/write only/none" ersetzen und so die entsprechenden Rechte vergeben…
     
  3. kurtiiii

    kurtiiii New Member

    und ich war so zuversichtlich ...
    Aber leider hat das mit dem Script nicht geklappt. Vielleicht habe ich da was falsch gemacht. Ist aber eher unwarscheinlich. Habe Deinen Code als Script abgespeichert und an ein Volume gehängt. Die Veränderung war aber gleich null.
    Somit stehe ich wieder am Anfang und sehne mich nach weiteren möglichen Lösungen ...
     
  4. macbike

    macbike ooer eister

    Es wirkt nur auf die Objekte, die direkt in diesen Ordner kopiert werden, auch alle vorher vorhandenen werden nicht verändert…
     
  5. kurtiiii

    kurtiiii New Member

    genauso hab ich's getestet. direkt auf dem volume, an dem das script hängt, habe ich den testordner angelegt. keine reaktion. außerdem würde mir das so nicht weiterhelfen. ich kann nicht an jeden neuen ordner das script anhängen ...
    trotzdem besten dank.

    es muss doch noch einen anderen weg geben!
     
  6. macbike

    macbike ooer eister

    So genau kenne ich mich leider nicht aus, aber gehen tut das bestimmt, nur wie…? :klimper:
     
  7. Florian

    Florian New Member

    Die Lösung Deines Problems heißt SharePoints.

    Wenn Du SharePoints hier in der Suche eingibst, findest Du auch viele Threads, die sich mit ähnlichen Problemen (und deren Lösung) beschäftigen.

    Gruß,
    Florian
     
  8. kurtiiii

    kurtiiii New Member

    Danke Florian,
    aber SharePoints ist nicht meine Lösung sondern Teil des Problems. Ich habe die Freigabe mit SharePoint eingerichtet. Doch ist es anscheinend dem Mac nicht möglich, Zugriffsrechte nach Gruppen zu verteilen. Somit kann ich wohl nichts unternehmen, damit Benutzer1 eine Datei anlget auf die Benutzer2 volle Schreib- und Leserechte erhält. Ein unsinniger Schrott ist das.
    Habe mich auf Deinen Rat durch endlose Threads gekämpft, um mir Sachen anzuhören wie "Ordner über das Terminal anlegen" etc. Jetzt ist meine Geduld zu ende. Benutzer werden demnächst abgeschafft! So ein heilloser Schwachsinn.

    Alles Gute,
    Lukas.
     
  9. Florian

    Florian New Member

    Das verstehe ich nicht. Benutzt Du etwa eine uralte Version von SharePoints?
    Ich verwende für 10.3 die Version 3.5.1 (es gibt auch eine neuere Version für 10.4.). Im SharePoints-Fenster ist oben der Reiter "Gruppen", unter dem Du einzelne Benutzer zu Gruppen zusammenfassen kannst.
    Zitat aus der Entwickler-Homepage:

    To add a new group using SharePoints, follow these 4 steps.
    1. Click on the Groups tab.
    2. Fill in the information for the group.
    3. Click Add New Group.
    4. Add new users from the user list to the newly created group.

    Das funktioniert bei mir auch prima! Vielleicht solltest Du einmal um den Block laufen, Deinen Puls runterfahren und dann _exakt_ Dein Problem schildern!

    Gruß,
    Florian
     
  10. kurtiiii

    kurtiiii New Member

    Ist die aktuellste Version. Gruppen sind definiert. Ich habe - denke ich - alles richtig gemacht. Mein Problem hat ja nichts mit Gruppen zu tun, sondern damit dass Benutzer2 keine Schreibrechte für Dateien von Benutzer1 hat, obwohl beide in der selben Gruppe sind. Denn die Schreibrechte für die Gruppe von Benutzer1 sind auch bei Dateien die Benutzer1 selbst anlegt nicht gegeben.
    Damit bin ich wieder am Anfang meines Problems. Ich möchte den Mac so konfigurieren, dass ich vom PC als Benutzer1 eine Datei anlege, auf die sowohl Benutzer1 selber als auch die Gruppe von Benutzer1 (Admin) mit Schreibrechten zugreifen kann. Dann könnte nämlich auch Benutzer2 (auch Admin) Schreibrechte erhalten.

    Hast Du noch eine Idee Florian. Ich finde deinen Eifer sehr lobenswert. Bei mir herrscht mittlerweile die Frustration vor. Ich könnte jedem, der mit seinem "Mac ist ja so toll" oder "Auf Mac ist alles so einfach" Gequatsche daher kommt, eine ...

    Lukas.
     
  11. Florian

    Florian New Member

    OK, dann gehen wir Schritt für Schritt vor:

    1) Du legst auf dem Mac einen Ordner an, in dem die zu bearbeitenden Dateien routinemäßig gespeichert werden und gibst diesem einen eindeutigen Namen ("Projekt XY - Austausch", o.ä.).

    2) Du startest SharePoints und legst unter "Gruppen" eine Gruppe mit allen Benutzern an, die auf dem neu angelegten Ordner Schreib- und Leserechte haben sollen (ebenfalls mit eindeutigem Namen).

    3) Unter "Normale Freigaben" bei SharePoints gibst Du einen neuen Freigabenamen (Du errätst es: ebenfalls eindeutig) ein und gibst darunter den Pfad zu dem neuen Ordner aus 1) ein.

    4) Du schaltest die Freigabearten AFS und SMB ein - AFS für die Kommunikation zwischen Macs, SMB für die Kommunikation mit Windows-Rechnern.

    5) Nun klickst Du auf den Button "System Einstellungen zeigen", setzt das Häkchen bei "Eigentümer und Gruppen zeigen" und gibst den Eigentümer (Admin des Host-Rechners) und die Gruppe (siehe 2)) an.
    Dann stellst Du die Rechte für Eigentümer wie Gruppe auf r/w.

    6) Schließlich klickst Du im Hauptfenster auf "Neue Freigabe hinzufügen".

    7) Zum Schluß markierst Du das Volume des Host-Macs, auf dem sich der Austausch-Ordner befindet, drückst Apfel-i und setzt im sich jetzt öffnenden Informationsfenster unter "Eigentümer und Zugriffsrechte" das Häkchen bei "Eigentümer auf diesem Volume ignorieren".

    Jetzt müßte es klappen!

    Gruß,
    Florian

    Nachtrag: In den Systemeinstellungen/Sharing des Host-Rechners müssen "Personal File Sharing" und "Windows Sharing" aktiviert sein.
     
  12. kurtiiii

    kurtiiii New Member

    Hi Florian,
    jetzt nicht nur ein kleinen Dank sondern ein großes Lob. Die Sache Läuft jetzt. Lag wahrscheinlich an der Option "Eigentümer auf diesem Volume ignorieren".

    Also, alles Gute.
    Lukas.
     
  13. Florian

    Florian New Member

    Bitte, gerne!

    Gruß,
    Florian
     
  14. bee

    bee New Member

    sauber, der typ!
    gut gemacht,

    gruss
    bee
     
  15. robdus

    robdus warum gibt es Köln?

    von mir auch ein dickes "Hut ab"...

    :applausfresse:
     

Diese Seite empfehlen